Skip to main content
CVE-2024-26306VulnerabilityPublished Updated

iPerf3 before 3.17, when used with OpenSSL before 3.2.0 as a server with RSA authentication, allows a timing side

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-26306· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in 3.17 : update iperf when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.15.9
EPSS
1.0% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.17, 3.2.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade esnet/iperf to 3.17; openssl/openssl to 3.2.0.

Affected software

ProductAffectedFixed in
GitHubesnet/iperfpkg:github/esnet/iperfOther threatsAffected
  • <3.17
Fixed in
  • 3.17
GitHubopenssl/opensslpkg:github/openssl/opensslOther threatsAffected
  • <3.2.0
Fixed in
  • 3.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

No explicit patch or remediation is stated in the provided data. Since the vulnerability involves iPerf3 before 3.17 and OpenSSL before 3.2.0, upgrading iPerf3 to version 3.17 or later and OpenSSL to version 3.2.0 or later is recommended to mitigate this issue. Monitor vendor advisories for official fixes or guidance.

Description

A timing side channel vulnerability exists in iPerf3 versions before 3.17 when used as a server with OpenSSL versions before 3.2.0 employing RSA authentication. This vulnerability could allow an attacker to recover plaintext credentials by sending a large number of decryption requests, exploiting the timing differences in RSA operations.

References

Community reviews

Loading reviews…