Skip to main content
VulnerabilityPublished Updated

CVE-2025-15467: Issue summary · Parsing CMS AuthEnvelopedData or EnvelopedData message with maliciously crafted AEAD

Affects nodejsSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 3.0.2-0ubuntu1.21 : patch nodejs as a priority.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.0.2-0ubuntu1.21, 3.0.2-0ubuntu1.21+Fips1, 3.0.13-0ubuntu3.7 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10edk2pkg:deb/ubuntu/edk2?arch=source&distro=stonkingOther threatsAffected
  • 2025.11-3ubuntu7 – 2026.05-2ubuntu3
5 affected builds
Fixed in–
Ubuntu 26.10edk2-hwepkg:deb/ubuntu/edk2-hwe?arch=source&distro=stonkingOther threatsAffected
  • 2025.11-3ubuntu8 – 2026.05-2ubuntu3
5 affected builds
Fixed in–
Ubuntu 26.04 LTSedk2pkg:deb/ubuntu/edk2?arch=source&distro=resoluteOther threatsAffected
  • 2025.02-8ubuntu3 – 2025.11-3ubuntu7.3
5 affected builds
Fixed in–
Ubuntu 26.04 LTSedk2-hwepkg:deb/ubuntu/edk2-hwe?arch=source&distro=resoluteOther threatsAffected
  • =2025.11-3ubuntu6
  • =2025.11-3ubuntu8
  • =2025.11-3ubuntu8.2
Fixed in–
Ubuntu 26.04 LTSopensslpkg:deb/ubuntu/openssl?arch=source&distro=resoluteOther threatsAffected
  • <3.5.5-1ubuntu1
Fixed in
  • 3.5.5-1ubuntu1
Ubuntu 25.10edk2pkg:deb/ubuntu/edk2?arch=source&distro=questingOther threatsAffected
  • 2025.02-3ubuntu2 – 2025.02-8ubuntu3.2
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Issue summary: Parsing CMS AuthEnvelopedData or EnvelopedData message with maliciously crafted AEAD parameters can trigger a stack buffer overflow. Impact summary: A stack buffer overflow may lead to a crash, causing Denial of Service, or potentially remote code execution. When parsing CMS (Auth)EnvelopedData structures that use AEAD ciphers such as AES-GCM, the IV (Initialization Vector) encoded in the ASN.1 parameters is copied into a fixed-size stack buffer without verifying that its length fits the destination. An attacker can supply a crafted CMS message with an oversized IV, causing a stack-based out-of-bounds write before any authentication or tag verification occurs. Applications and services that parse untrusted CMS or PKCS#7 content using AEAD ciphers (e.g., S/MIME (Auth)EnvelopedData with AES-GCM) are vulnerable. Because the overflow occurs prior to authentication, no valid key material is required to trigger it. While exploitability to remote code execution depends on platform and toolchain mitigations, the stack-based write primitive represents a severe risk. The FIPS modules in 3.6, 3.5, 3.4, 3.3 and 3.0 are not affected by this issue, as the CMS implementation is outside the OpenSSL FIPS module boundary. OpenSSL 3.6, 3.5, 3.4, 3.3 and 3.0 are vulnerable to this issue. OpenSSL 1.1.1 and 1.0.2 are not affected by this issue. Impact summary: A stack buffer overflow may lead to a crash, causing Denial of Service, or potentially remote code execution. When parsing CMS AuthEnvelopedData structures that use AEAD ciphers such as AES-GCM, the IV (Initialization Vector) encoded in the ASN.1 parameters is copied into a fixed-size stack buffer without verifying that its length fits the destination. An attacker can supply a crafted CMS message with an oversized IV, causing a stack-based out-of-bounds write before any authentication or tag verification occurs. Applications and services that parse untrusted CMS or PKCS#7 content using AEAD ciphers (e.g., S/MIME AuthEnvelopedData with AES-GCM) are vulnerable. Because the overflow occurs prior to authentication, no valid key material is required to trigger it. While exploitability to remote code execution depends on platform and toolchain mitigations, the stack-based write primitive represents a severe risk. The FIPS modules in 3.6, 3.5, 3.4, 3.3 and 3.0 are not affected by this issue, as the CMS implementation is outside the OpenSSL FIPS module boundary. OpenSSL 3.6, 3.5, 3.4, 3.3 and 3.0 are vulnerable to this issue. OpenSSL 1.1.1 and 1.0.2 are not affected by this issue.

References

Community reviews

Loading reviews…