Skip to main content
VulnerabilityPublished Updated

CVE-2025-64178: image cache API endpoint · Jellysweep Uses Uncontrolled Data

Affects github.com/jon4hz/jellysweepSource GCVE Database

0
Compare
Authoritative record:CVE-2025-64178· High 8.9

Not known to be exploited · CVSS 8.9 High : upgrade to 0.13.0 soon.

Data as of 4 Nov 2026, 18:46 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.9
Patch
Available – fixed in 0.13.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade github.com/jon4hz/jellysweep to 0.13.0.

Affected software

ProductAffectedFixed in
Gogithub.com/jon4hz/jellysweepAffected
  • <0.13.0
Fixed in
  • 0.13.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Jellysweep to version 0.13.0 or later, where this vulnerability is fixed. The fix involves moving the vulnerable library to internal use and correcting the handling of the URL parameter in the /api/images/cache endpoint. No additional mitigation is required if the system is updated.

Description

Jellysweep versions prior to 0.13.0 contain a vulnerability in the /api/images/cache endpoint that allows authenticated users to supply a URL parameter which the server uses to download arbitrary content. This flaw enables potential server-side request forgery (SSRF) by making the server fetch unintended resources. The issue is fixed in version 0.13.0 where the vulnerable library was moved to internal use.

References

Community reviews

Loading reviews…