CVE-2024-26278: Joomla · [20240705] - Core - XSS in com_fields default field value
Affects joomlaSource GCVE Database
Not known to be exploited : upgrade to 5.1.2 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.1.2
Exploitation evidence
Disclosed: evidence found.
CVE published 3 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade joomla to 5.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamijoomlapkg:bitnami/joomlaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade Joomla to version 5.1.2 or later to remediate the issue. Until patched, avoid using untrusted input in custom field default values or apply manual input sanitization as a temporary measure.
Description
A cross-site scripting (XSS) vulnerability exists in Joomla's Custom Fields component due to improper input filtering in the default field value. This flaw affects Joomla versions from 3.7.0 up to but not including 5.1.2. The vulnerability allows injection of malicious scripts via the default field value, potentially impacting users who interact with affected fields.