Skip to main content
VulnerabilityPublished Updated

CVE-2024-47546: GHSL-2024-243 · GStreamer has an integer underflow in extract_cc_from_data leading to OOB-read

Affects jreSource GCVE Database

0

Not known to be exploited : upgrade to 8.0.451 or 1.8.0 soon.

Data as of 26 Oct 2026, 14:05 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.451, 1.8.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade jre to 8.0.451 or 1.8.0.

Affected software

ProductAffectedFixed in
Bitnamijrepkg:bitnami/jreOther threatsAffected
  • <1.8.0
  • >=1.9.0 <8.0.451
Fixed in
  • 1.8.0
  • 8.0.451

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in GStreamer version 1.24.10. Users should upgrade to version 1.24.10 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.

Description

An integer underflow vulnerability exists in the extract_cc_from_data function within the qtdemux.c file of the GStreamer library. Specifically, when processing the FOURCC_c708 case, a subtraction operation atom_length - 8 can underflow if atom_length is less than 8, causing an out-of-bounds read via g_memdup2. This vulnerability is fixed in version 1.24.10.

References

Community reviews

Loading reviews…