Skip to main content
VulnerabilityPublished Updated

Juniper: Stack overflow on deeply nested GraphQL documents

Affects juniperSource GCVE Database

0

CVSS 7.5 High : upgrade to 0.17.2 soon.

Data as of 29 Oct 2026, 17:51 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.17.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

What to do

Upgrade juniper to 0.17.2.

Affected software

ProductAffectedFixed in
crates.iojuniperpkg:cargo/juniperOther threatsAffected
  • >=0.0.0-0 <0.17.2
Fixed in
  • 0.17.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Juniper version 0.17.2 or later, which enforces limits on GraphQL document nesting depth and token count to prevent stack overflow. Alternatively, use the RootNode::limit_depth() and RootNode::limit_tokens() APIs to configure these limits manually. No other mitigation is required as the vulnerability is addressed by these limits.

Description

Juniper versions prior to 0.17.2 contain a stack overflow vulnerability triggered by deeply nested GraphQL documents. The parser recursively processes each nesting level without limits, allowing an attacker to cause a stack overflow by submitting documents with excessive nesting or long chains of fragment spreads. This results in the server process aborting and dropping all ongoing requests. The vulnerability requires no authentication to exploit. Version 0.17.2 and later mitigate this by enforcing limits on nesting depth and token count.

References

Community reviews

Loading reviews…