Skip to main content
VulnerabilityPublished Updated

CVE-2025-49655: Keras framework vulnerable to deserialization of untrusted data

Affects kerasSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.11.3 as a priority.

Data as of 27 Oct 2026, 18:29 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.11.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade keras to 3.11.3.

Affected software

ProductAffectedFixed in
PyPIkerasAffected
  • >=3.11.0 <3.11.3
Fixed in
  • 3.11.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Keras to version 3.11.3 or later, where this vulnerability is fixed. Until then, avoid loading untrusted Keras files, especially those containing TorchModuleWrapper classes. No other mitigations are specified.

Description

Keras versions 3.11.0 through 3.11.2 are vulnerable to deserialization of untrusted data, allowing arbitrary code execution when loading maliciously crafted Keras files containing a TorchModuleWrapper class. This vulnerability can be triggered via both local and remote files, bypassing safe mode protections. The issue is fixed in version 3.11.3.

References

Community reviews

Loading reviews…