CVE-2025-40233: kernel security update
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 5.10.0-339.0.0.240.oe2203sp4 as a priority.
Data as of 29 Oct 2026, 11:02 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.10.0-339.0.0.240.oe2203sp4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Linux kernel to 5.10.0-339.0.0.240.oe2203sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 22.03-LTS-SP4kernelpkg:rpm/openEuler/kernel&distro=openEuler-22.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to Linux kernel version 5.10.0-339.0.0.240.oe2203sp4 or later. This update clears the extent map cache properly in ocfs2 and corrects conduit reference counting in DSA. No additional mitigation steps are indicated beyond applying the official fix.
Description
CVE-2025-40233 is a critical vulnerability in the Linux kernel affecting the ocfs2 filesystem and the DSA network subsystem. The ocfs2 flaw involves stale extent map cache after extent moves or defragmentation, causing a kernel BUG_ON due to mismatched extent flags. The DSA issue relates to improper reference counting of conduit network devices, potentially leading to stale pointers and resource management errors. The vulnerability is fixed in Linux kernel version 5.10.0-339.0.0.240.oe2203sp4.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4591 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-40233 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-71152 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-43075 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53146 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53189 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53253 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53254 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53349 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-63833 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-64277 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-64363 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-64532 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-64541 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-68479 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-74498 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-74507 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-74508 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-74581 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-74583 (opens in a new tab)