CVE-2026-28490: Kimi cli · Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle
Affects kimi-cliSource GCVE Database
Not known to be exploited · CVSS 8.3 High : upgrade to 1.17.0 soon.
Data as of 1 Nov 2026, 11:02 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.17.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade kimi-cli to 1.17.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewkimi-clipkg:brew/kimi-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available for this vulnerability. Users should update to a patched version of the affected software (kimi-cli >=1.17.0 or the corresponding fixed Authlib version). Since the vulnerability is active by default, applying the official patch is the recommended mitigation.
Description
A cryptographic padding oracle vulnerability (CVE-2026-28490) affects the Authlib Python library's implementation of the JSON Web Encryption (JWE) RSA1_5 key management algorithm. The vulnerability arises because Authlib disables the Bleichenbacher padding oracle mitigation by raising a distinct exception on invalid padding, enabling a reliable exception oracle. This issue is present by default in all Authlib installations without special configuration and was confirmed in Authlib version 1.6.8 with cryptography 46.0.5. A fix is available. The affected product is kimi-cli versions >=0.40 and <1.17.0.
References
- github.com/authlib/authlib/security/advisories/GHSA-7432-952r-cw78 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-28490 (opens in a new tab)
- github.com/authlib/authlib/commit/48b345f29f6c459f11c6a40162b6c0b742ef2e22 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.6.9 (opens in a new tab)