Skip to main content
VulnerabilityPublished Updated

Kimi cli: FastMCP Auth Integration Allows for Confused Deputy Account Takeover

Affects kimi-cliSource GCVE Database

0

CVSS 7.3 High : upgrade to 1.44.0 soon.

Data as of 18 Sep 2026, 01:33 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.44.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

What to do

Upgrade kimi-cli to 1.44.0.

Affected software

ProductAffectedFixed in
Homebrewkimi-clipkg:brew/kimi-cliOther threatsAffected
  • >=0.42_1 <1.44.0
Fixed in
  • 1.44.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for kimi-cli versions >=0.42_1 and <1.44.0 that addresses this confused deputy vulnerability. Users should update to the fixed version to prevent exploitation. No additional mitigation steps are indicated by the vendor advisory.

Description

The kimi-cli FastMCP authentication integration allows a confused deputy attack leading to account takeover. The FastMCP server acts both as an OAuth client to a downstream authorization server (e.g., Entra ID) and as an authorization server to its clients. Due to the use of a static client registration in Entra ID and persistent user consent cookies, an attacker controlling their own MCP client can leverage the victim's prior consent to the static client to bypass re-authorization prompts. This enables the attacker to obtain authorization codes and potentially take over the victim's account. A patch is available for this vulnerability.

References

Community reviews

Loading reviews…