Kimi cli: FastMCP updated to MCP 1.23+ due to CVE-2025-66416
Affects kimi-cliSource GCVE Database
0
Mentioned vulnerabilities
Severity
MediumRated by Threat Radar
- Patch
- Available – fixed in 1.44.0
Data as of 18 Sep 2026, 01:33 UTC
What to do
Upgrade kimi-cli to 1.44.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewkimi-clipkg:brew/kimi-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade FastMCP to version 2.14.0 or later, which enforces usage of MCP SDK version 1.23 or newer, thereby mitigating the vulnerability. Since a patch is available and recommended, users should apply this upgrade promptly.
Description
FastMCP versions prior to 2.14.0 allowed usage of MCP SDK versions earlier than 1.23, which are vulnerable to CVE-2025-66416. FastMCP itself does not directly use the affected MCP SDK components. Users should upgrade to FastMCP 2.14.0 or later to avoid exposure to this vulnerability.
References
Community reviews
Loading reviews…