Skip to main content
CVE-2026-85091VulnerabilityPublished Updated

Klibc: zlib versions 1.3.1.2 through 1.3.2 contain a heap buffer overflow vulnerability in the gz_vacate() function

Affects klibcSource GCVE Database

0

Not known to be exploited · CVSS 7.4 High · fixed in 1:1.3.dfsg-3.1ubuntu2.3 : patch klibc soon.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1:1.3.dfsg-3.1ubuntu2.3, 1:1.3.dfsg+really1.3.1-1ubuntu3.2, 1:1.3.dfsg+really1.3.2-3ubuntu1.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu zlib to 1:1.3.dfsg-3.1ubuntu2.3 (package) or 1:1.3.dfsg+really1.3.1-1ubuntu3.2 (package) or 1:1.3.dfsg+really1.3.2-3ubuntu1.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10klibcpkg:deb/ubuntu/klibc?arch=source&distro=stonkingOther threatsAffected
  • =2.0.14-1ubuntu2
Fixed in–
Ubuntu 26.10zlibpkg:deb/ubuntu/zlib?arch=source&distro=stonkingOther threatsAffected
  • <1:1.3.dfsg+really1.3.2-3ubuntu1.1
Fixed in
  • 1:1.3.dfsg+really1.3.2-3ubuntu1.1
Ubuntu 26.10zsyncpkg:deb/ubuntu/zsync?arch=source&distro=stonkingOther threatsAffected
  • =0.6.2-9
  • =0.6.3-2
Fixed in–
Ubuntu 26.04 LTSklibcpkg:deb/ubuntu/klibc?arch=source&distro=resoluteOther threatsAffected
  • =2.0.14-1ubuntu1
  • =2.0.14-1ubuntu2
Fixed in–
Ubuntu 26.04 LTSzlibpkg:deb/ubuntu/zlib?arch=source&distro=resoluteOther threatsAffected
  • <1:1.3.dfsg+really1.3.1-1ubuntu3.2
Fixed in
  • 1:1.3.dfsg+really1.3.1-1ubuntu3.2
Ubuntu 26.04 LTSzsyncpkg:deb/ubuntu/zsync?arch=source&distro=resoluteOther threatsAffected
  • =0.6.2-8
  • =0.6.2-9
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

zlib versions 1.3.1.2 through 1.3.2 contain a heap buffer overflow vulnerability in the gz_vacate() function. This occurs during non-blocking gzwrite() operations when stale external buffer pointers are processed. The overflow can be triggered by calling gzprintf() or gzvprintf() after a write stall, leading to an unchecked memmove() that writes beyond the internal input buffer boundary.

References

Community reviews

Loading reviews…