Skip to main content
CVE-2025-9708VulnerabilityPublished Updated

KubernetesClient: Kubernetes C# client accepts certificates from any CA without properly verifying the trust chain

Affects KubernetesClientSource GCVE Database

0
Compare
Authoritative record:CVE-2025-9708· Medium 6.8

Not known to be exploited · CVSS 6.8 Medium : upgrade to 17.0.14 when convenient.

Data as of 4 Nov 2026, 18:17 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (kubernetes)CVSS 3.16.8
Patch
Available – fixed in 17.0.14
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade KubernetesClient to 17.0.14.

Affected software

ProductAffectedFixed in
NuGetKubernetesClientAffected
  • <17.0.14
Fixed in
  • 17.0.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the Kubernetes C# client to version 17.0.14 or later, where the certificate validation flaw has been fixed. Applying this official patch fully mitigates the vulnerability.

Description

The Kubernetes C# client contains a vulnerability in its certificate validation logic that improperly accepts certificates from any Certificate Authority without verifying the trust chain. This flaw could allow attackers to present forged certificates, enabling man-in-the-middle attacks and impersonation of the Kubernetes API server. The issue affects versions prior to 17.0.14 and has been assigned CVE-2025-9708. A patch is available in version 17.0.14 to address this vulnerability.

References

Community reviews

Loading reviews…