Skip to main content
CVE-2025-34134VulnerabilityPublished

Nagios XI · Kwetsbaarheden Verholpen

Affects Nationaal Cyber Security Centrum Nagios EnterprisesSource GCVE Database

0
Compare
Authoritative record:CVE-2025-34134· Critical 9.4

Not known to be exploited · CVSS 9.4 Critical : upgrade to 2024R1.4.2 as a priority.

Data as of 29 Oct 2026, 23:42 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2024R1.4.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade XI to 2024R1.4.2.

Affected software

ProductAffectedFixed in
NagiosXIAffected
  • <2024R1.4.2
Fixed in
  • 2024R1.4.2

AI-suggested

Fixed versions 2024R1.4.2 and 2024R2 have been released by Nagios to address these vulnerabilities. Users should upgrade to these versions to remediate the issues. No additional mitigation guidance is provided or required based on the vendor information.

Description

Nagios has addressed multiple vulnerabilities in Nagios XI versions prior to 2024R1.4.2 and 2024R2. The specific flaws relate to issues categorized under CWE-78 (OS Command Injection), CWE-732 (Incorrect Permission Assignment for Critical Resource), and CWE-497 (Exposure of System Information Through Error Message). No CVSS score or detailed impact information is provided. No known exploits are reported in the wild. The affected versions are not explicitly listed beyond the indication that versions before 2024R1.4.2 and 2024R2 are vulnerable.

References

Community reviews

Loading reviews…