Kyverno before 1.19.2 contains a denial of service vulnerability that allows namespaced policy authors to exhaust
Affects kyvernoSource GCVE Database
Not known to be exploited · CVSS 8.3 High : upgrade to 1.19.2 soon.
Data as of 5 Nov 2026, 04:27 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.7 |
- Patch
- Available – fixed in 1.19.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade kyverno/kyverno to 1.19.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubkyverno/kyvernopkg:github/kyverno/kyvernoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Kyverno version 1.19.2. Users should upgrade to version 1.19.2 or later to remediate this vulnerability. No other mitigation steps are indicated.
Description
Kyverno versions prior to 1.19.2 have a denial of service vulnerability where namespaced policy authors can submit specially crafted wildcard patterns. This causes excessive CPU usage in the admission controller, leading to cluster-wide webhook timeouts that block resource operations.