Skip to main content
VulnerabilityPublished Updated

CVE-2024-27444: LangChain Experimental vulnerable to arbitrary code execution

Affects langchain-experimentalSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-27444· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.0.52 as a priority.

Data as of 27 Oct 2026, 18:30 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.0.52
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade langchain-experimental to 0.0.52.

Affected software

ProductAffectedFixed in
PyPIlangchain-experimentalAffected
  • <0.0.52
Fixed in
  • 0.0.52

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade langchain_experimental to version 0.0.52 or later, where this vulnerability is fixed. Since a patch is available, applying the official fix is the recommended mitigation. No additional mitigations are indicated by the vendor advisory.

Description

LangChain Experimental versions prior to 0.0.52 contain a critical vulnerability (CVE-2024-27444) that allows attackers to bypass previous fixes and execute arbitrary code by exploiting certain Python attributes. This flaw affects langchain_experimental before 0.0.52 and the broader LangChain before 0.1.8. The vulnerability arises because attributes such as __import__, __subclasses__, __builtins__, and others are not properly restricted, enabling code execution.

References

Community reviews

Loading reviews…