Skip to main content
VulnerabilityPublished

CVE-2026-5917: libgit2 security update

Affects libgit2Source GCVE Database

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 1.7.2-3.oe2403sp3 soon.

Data as of 29 Oct 2026, 10:48 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.4% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.2-3.oe2403sp3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libgit2 to 1.7.2-3.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3libgit2pkg:rpm/openEuler/libgit2&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <1.7.2-3.oe2403sp3
Fixed in
  • 1.7.2-3.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in libgit2 version 1.7.2-3.oe2403sp3. Users should upgrade to this version or later to remediate the issue. No additional mitigations are specified by the vendor advisory.

Description

A shell command injection vulnerability exists in libgit2 versions before 1.8.7 and 1.9.0 before 1.9.7 when built with the libssh2 SSH backend. The vulnerability allows remote attackers to execute arbitrary commands on an SSH server by supplying a repository path containing unescaped shell metacharacters. This occurs due to improper escaping in the gen_proto() function in ssh_libssh2.c, which inserts the repository path directly into a shell command string. An attacker can exploit this by crafting a malicious submodule URL in a .gitmodules file that triggers command execution during a recursive clone.

References

Community reviews

Loading reviews…