libmt32emu before 2.8.4 contains a heap buffer overflow vulnerability in MidiStreamParserImpl::parseSysex that allows
Source GCVE Database
Not known to be exploited · CVSS 8.5 High : upgrade to 2.8.4 soon.
Data as of 4 Nov 2026, 16:43 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.5 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.8 |
- Patch
- Available – fixed in 2.8.4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade libmt32emu to 2.8.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| muntlibmt32emu | Affected
| Fixed in
|
GitHublibmt32emupkg:github/libmt32emuOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 2.8.4 or later addresses this vulnerability. Users should upgrade to libmt32emu version 2.8.4 or later to remediate this issue. No vendor advisory or patch links were provided, so verify the availability of the fix from the official libmt32emu sources before deployment.
Description
libmt32emu versions before 2.8.4 have a heap buffer overflow vulnerability in the MidiStreamParserImpl::parseSysex function. This flaw allows attackers to write beyond allocated heap memory by supplying oversized unterminated SysEx messages. Exploitation involves feeding more than 32768 SysEx data bytes through the mt32emu_parse_stream API via MIDI files, ports, or sequencer clients, leading to heap corruption and application crashes.
References
- nvd.nist.gov/vuln/detail/CVE-2026-121941 (opens in a new tab)
- github.com/munt/munt/issues/149 (opens in a new tab)
- github.com/munt/munt/commit/1749f7fed5cdb3a9015acce076a1512b1615dc3b (opens in a new tab)
- github.com/munt/munt/blob/libmt32emu_2_8_3/mt32emu/src/MidiStreamParser.cpp (opens in a new tab)
- hackmd.io/@haindpwn/munt-midistreamparser-oversized-sysex-heap-overflow (opens in a new tab)
- vulncheck.com/advisories/libmt32emu-before-2.8.4-heap-buffer-overflow-via-midistreamparserimpl-parsesysex (opens in a new tab)