CVE-2026-54291: Libpgjava · pgjdbc is an open source postgresql JDBC Driver
Affects libpgjavaSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium · fixed in 42.7.12 : update libpgjava when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 42.7.12
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10libpgjavapkg:deb/ubuntu/libpgjava?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlibpgjavapkg:deb/ubuntu/libpgjava?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10libpgjavapkg:deb/ubuntu/libpgjava?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to pgjdbc version 42.7.12 or later, where this vulnerability is fixed. No other mitigations are indicated.
Description
A vulnerability in the pgjdbc PostgreSQL JDBC Driver versions 42.7.4 through 42.7.11 allows silent downgrade of channelBinding=require connections from SCRAM-SHA-256-PLUS with channel binding to plain SCRAM-SHA-256 without channel binding. This downgrade removes the intended man-in-the-middle protection. The issue is fixed in version 42.7.12.
References
- ubuntu.com/security/CVE-2026-54291 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-54291 (opens in a new tab)
- github.com/pgjdbc/pgjdbc/security/advisories/GHSA-j92g-9f8w-j867 (opens in a new tab)
- github.com/ongres/scram/releases/tag/3.3 (opens in a new tab)
- github.com/pgjdbc/pgjdbc/commit/77df98e4e66c12936ded3478a0954f6f580bad99 (opens in a new tab)