Skip to main content
VulnerabilityPublished Updated

CVE-2026-91767: Libphp · Heap-buffer-overflow in php_openssl_matches_wildcard_name on crafted server cert wildcard CN

Affects libphpSource GCVE Database

0
Compare
Authoritative record:CVE-2026-91767· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 8.5.11 : update libphp when convenient.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.11, 8.4.26, 8.3.35 +1
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libphp to 8.5.11, 8.4.26, 8.3.35 or 8.2.34.

Affected software

ProductAffectedFixed in
Bitnamilibphppkg:bitnami/libphpOther threatsAffected
  • >=8.2.0 <8.2.34
  • >=8.3.0 <8.3.35
  • >=8.4.0 <8.4.26
  • >=8.5.0 <8.5.11
Fixed in
  • 8.2.34
  • 8.3.35
  • 8.4.26
  • 8.5.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading libphp to versions 8.2.34, 8.3.35, 8.4.26, or 8.5.11 or later. Since a patch is available and fixed versions are released, remediation should be performed promptly to prevent exploitation.

Description

A heap-buffer-overflow vulnerability exists in the php_openssl_matches_wildcard_name() function of libphp when processing TLS server certificates with wildcard names longer than the hostname being verified. This flaw can cause the PHP client to read memory beyond the allocated heap buffer. The vulnerability is reachable from any default client stream with verify_peer_name enabled, which is the default setting. Fixed versions are available.

References

Community reviews

Loading reviews…