Skip to main content
VulnerabilityPublished Updated

CVE-2026-25646: Libpng · Prior to 1.6.55, an out-of-bounds read vulnerability exists in the png_set_quantize() API

Affects libpngSource GCVE Database

0
Authoritative record:CVE-2026-25646· High 8.3

Not known to be exploited · CVSS 8.3 High · fixed in 1.2.50-1ubuntu2.14.04.3+esm1 : patch libpng soon.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.50-1ubuntu2.14.04.3+esm1, 1.2.54-1ubuntu1.1+esm2, 1.6.20-2ubuntu0.1~esm3 +6
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlibpng1.6pkg:deb/ubuntu/libpng1.6?arch=source&distro=resoluteOther threatsAffected
  • <1.6.55-1
Fixed in
  • 1.6.55-1
Ubuntu 25.10libpng1.6pkg:deb/ubuntu/libpng1.6?arch=source&distro=questingOther threatsAffected
  • <1.6.50-1ubuntu0.4
Fixed in
  • 1.6.50-1ubuntu0.4
Ubuntu 24.04 LTSlibpng1.6pkg:deb/ubuntu/libpng1.6?arch=source&distro=nobleOther threatsAffected
  • <1.6.43-5ubuntu0.5
Fixed in
  • 1.6.43-5ubuntu0.5
Ubuntu 22.04 LTSlibpng1.6pkg:deb/ubuntu/libpng1.6?arch=source&distro=jammyOther threatsAffected
  • <1.6.37-3ubuntu0.4
Fixed in
  • 1.6.37-3ubuntu0.4
Ubuntu Pro 20.04 LTSlibpng1.6pkg:deb/ubuntu/libpng1.6?arch=source&distro=esm-infra/focalOther threatsAffected
  • <1.6.37-2ubuntu0.1~esm2
Fixed in
  • 1.6.37-2ubuntu0.1~esm2
Ubuntu Pro 18.04 LTSlibpng1.6pkg:deb/ubuntu/libpng1.6?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <1.6.34-1ubuntu0.18.04.2+esm2
Fixed in
  • 1.6.34-1ubuntu0.18.04.2+esm2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to 1.6.55, an out-of-bounds read vulnerability exists in the png_set_quantize() API function. When the function is called with no histogram and the number of colors in the palette is more than twice the maximum supported by the user's display, certain palettes will cause the function to enter into an infinite loop that reads past the end of an internal heap-allocated buffer. The images that trigger this vulnerability are valid per the PNG specification. This vulnerability is fixed in 1.6.55.

References

Community reviews

Loading reviews…