Skip to main content
CVE-2026-33416VulnerabilityPublished Updated

SUSE · libpng12-0-1.2.59-5.1 on GA media

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-33416· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade SUSE libpng to 1.6.56 soon.

Data as of 4 Nov 2026, 00:31 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.6.56
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade libpng and pnggroup/libpng to 1.6.56.

Affected software

ProductAffectedFixed in
pnggrouplibpngAffected
  • >=1.2.1 <1.6.56
Fixed in
  • 1.6.56
GitHubpnggroup/libpngpkg:github/pnggroup/libpngOther threatsAffected
  • <1.6.56
Fixed in
  • 1.6.56

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should update to libpng12-0 version 1.2.59-5.1 on openSUSE Tumbleweed to apply the security fixes. Since the fixed package is available on the GA media, applying this update will mitigate the vulnerabilities.

Description

Multiple security issues have been fixed in the libpng12-0 package version 1.2.59-5.1 on the GA media of openSUSE Tumbleweed. These vulnerabilities affect the SUSE distribution and have been addressed in this specific package update.

References

Community reviews

Loading reviews…