Skip to main content
VulnerabilityPublished

CVE-2026-102556: libsoup security update

Affects libsoupSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-102556· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 2.74.2-28.oe2203sp4 soon.

Data as of 4 Nov 2026, 17:12 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.18.6
Patch
Available – fixed in 2.74.2-28.oe2203sp4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade libsoup to 2.74.2-28.oe2203sp4.

Affected software

ProductAffectedFixed in
openEuler 22.03-LTS-SP4libsouppkg:rpm/openEuler/libsoup&distro=openEuler-22.03-LTS-SP4Other threatsAffected
  • <2.74.2-28.oe2203sp4
Fixed in
  • 2.74.2-28.oe2203sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in libsoup version 2.74.2-28.oe2203sp4. Users and administrators should upgrade to this fixed version to mitigate the risks. No additional mitigation steps are indicated beyond applying the official patch.

Description

libsoup, an HTTP client/server library for GNOME, has multiple security flaws related to WebSocket frame handling. These include improper signal emission causing heap corruption or crashes, inadequate size checks during message reassembly leading to heap corruption, and a heap buffer overflow when constructing masked client frames with large payloads. These vulnerabilities affect versions prior to 2.74.2-28.oe2203sp4 and have been assigned CVE-2026-102556 among others. A high-severity fix is available in version 2.74.2-28.oe2203sp4.

References

Community reviews

Loading reviews…