Skip to main content
VulnerabilityPublished Updated

CVE-2026-6324: Libsoup2.4 · A flaw was found in libsoup

Affects libsoup2.4Source GCVE Database

0
Compare
Authoritative record:CVE-2026-6324· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium · fixed in 3.0.7-0ubuntu1+esm9 : update libsoup2.4 when convenient.

Data as of 3 Nov 2026, 23:30 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.14.8
Patch
Available – fixed in 3.0.7-0ubuntu1+esm9, 3.4.4-5ubuntu0.9, 3.6.6-1ubuntu3 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10libsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=stonkingOther threatsAffected
  • =2.74.3-10.1ubuntu5
Fixed in–
Ubuntu 26.10libsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=stonkingOther threatsAffected
  • <3.6.6-1ubuntu3
Fixed in
  • 3.6.6-1ubuntu3
Ubuntu 26.04 LTSlibsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=resoluteOther threatsAffected
  • =2.74.3-10.1ubuntu4
  • =2.74.3-10.1ubuntu5
Fixed in–
Ubuntu 26.04 LTSlibsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=resoluteOther threatsAffected
  • <3.6.6-1ubuntu0.1
Fixed in
  • 3.6.6-1ubuntu0.1
Ubuntu 25.10libsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=questingOther threatsAffected
  • 2.74.3-10 – 2.74.3-10.1ubuntu4.1
7 affected builds
Fixed in–
Ubuntu 25.10libsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=questingOther threatsAffected
  • 3.6.5-1 – 3.6.5-4ubuntu0.2
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. Fixed versions include 3.0.7-0ubuntu1+esm9, 3.4.4-5ubuntu0.9, 3.6.6-1ubuntu3, and 3.6.6-1ubuntu0.1. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A vulnerability in libsoup2.4's soup_body_input_stream_read_chunked() function allows a remote attacker to exploit an unsigned to signed conversion error by sending a malicious HTTP request. This flaw occurs when libsoup is used behind a non-libsoup proxy or as a proxy in front of a non-libsoup backend. Exploitation can lead to bypassing security controls, web cache poisoning, or unauthorized access. The vulnerability requires a specialized network setup involving HTTP keep-alive connection reuse and differing chunk-parsing logic between proxies. It has a medium severity rating with a CVSS score of 4.8 and has been fixed in versions 3.0.7-0ubuntu1+esm9 and later.

References

Community reviews

Loading reviews…