CVE-2026-12478: libsoup2.4, libsoup3 vulnerabilities
Affects libsoup2.4Source GCVE Database
Not known to be exploited · CVSS 4.8 Medium · fixed in 2.52.2-1ubuntu0.3+esm9 : update libsoup2.4 when convenient.
Data as of 4 Nov 2026, 04:01 UTC
- Patch
- Available – fixed in 2.52.2-1ubuntu0.3+esm9, 2.62.1-1ubuntu0.4+esm10, 2.70.0-1ubuntu0.5+esm5 +7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 14 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10libsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=stonkingOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlibsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu Pro 26.04 LTSlibsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlibsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlibsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlibsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available. Users should apply the security updates provided by Ubuntu for libsoup2.4 and libsoup3 as detailed in the Ubuntu Security Notice USN-8975-1. For Ubuntu Pro users, fixes are available via Extended Security Maintenance (ESM). Standard system updates will apply the necessary patches. No additional mitigation steps are required beyond applying these updates.
Description
Multiple vulnerabilities were discovered in libsoup2.4 and libsoup3 affecting various Ubuntu LTS and interim releases. These issues involve incorrect handling of WebSocket frames, data URIs, HTTP requests, proxy credentials, multipart messages, and fragmented or compressed WebSocket messages. Remote attackers could exploit these flaws to cause application crashes or potentially expose sensitive information. The vulnerabilities affect Ubuntu 16.04 LTS through 26.10 releases. Fixes are available in updated package versions distributed by Ubuntu, including Ubuntu Pro Extended Security Maintenance (ESM) updates.
References
- ubuntu.com/security/notices/USN-8975-1 (opens in a new tab)
- ubuntu.com/security/CVE-2026-12478 (opens in a new tab)
- ubuntu.com/security/CVE-2026-12547 (opens in a new tab)
- ubuntu.com/security/CVE-2026-12548 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102555 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102556 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102557 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102558 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102559 (opens in a new tab)
- ubuntu.com/security/CVE-2026-102560 (opens in a new tab)
- ubuntu.com/security/CVE-2026-103399 (opens in a new tab)