Skip to main content
VulnerabilityPublished Updated

CVE-2026-12549: Libsoup2.4 · The fix for CVE-2026-2443 was regressed by a subsequent rework commit that replaced

Affects libsoup2.4Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-12549· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium · fixed in 3.0.7-0ubuntu1+esm9 : update libsoup2.4 when convenient.

Data as of 3 Nov 2026, 23:14 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.0.7-0ubuntu1+esm9, 3.4.4-5ubuntu0.9, 3.6.6-1ubuntu3 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10libsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=stonkingOther threatsAffected
  • =2.74.3-10.1ubuntu5
Fixed in–
Ubuntu 26.10libsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=stonkingOther threatsAffected
  • <3.6.6-1ubuntu3
Fixed in
  • 3.6.6-1ubuntu3
Ubuntu 26.04 LTSlibsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=resoluteOther threatsAffected
  • <3.6.6-1ubuntu0.1
Fixed in
  • 3.6.6-1ubuntu0.1
Ubuntu Pro 26.04 LTSlibsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 2.74.3-10.1ubuntu4 – 2.74.3-10.1ubuntu5+esm4
6 affected builds
Fixed in–
Ubuntu 25.10libsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=questingOther threatsAffected
  • 2.74.3-10 – 2.74.3-10.1ubuntu4.1
7 affected builds
Fixed in–
Ubuntu 25.10libsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=questingOther threatsAffected
  • 3.6.5-1 – 3.6.5-4ubuntu0.2
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

The fix for CVE-2026-2443 was regressed by a subsequent rework commit that replaced specific overflow checks with a general signed comparison. When a client sends a Range request with a suffix length exceeding the content size, the resulting negative start value is not properly clamped, leading to malformed HTTP 206 responses and log flooding.

References

Community reviews

Loading reviews…