CVE-2026-0964: Libssh · A malicious SCP server can send unexpected paths that could make the client application
Affects libsshSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.0 Medium · fixed in 0.6.3-4.3ubuntu0.6+esm4 : update libssh when convenient.
Data as of 27 Oct 2026, 01:13 UTC
- Patch
- Available – fixed in 0.6.3-4.3ubuntu0.6+esm4, 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm6, 0.9.3-2ubuntu2.5+esm3 +3
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10libsshpkg:deb/ubuntu/libssh?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/xenialOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. Updating libssh to one of the fixed versions listed by Ubuntu (e.g., 0.6.3-4.3ubuntu0.6+esm4, 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm6, 0.9.3-2ubuntu2.5+esm3, 0.9.6-2ubuntu0.22.04.6, 0.10.6-2ubuntu0.3, or later) will remediate this vulnerability. Standard system updates will include these fixes. No additional mitigation steps are indicated by the vendor advisory.
Description
A vulnerability in libssh SCP client allows a malicious SCP server to send crafted paths that cause the client to overwrite files outside its working directory. This flaw can be exploited to create malicious executable or configuration files, potentially leading to arbitrary code execution. The issue is similar to CVE-2019-6111 in OpenSSH. Multiple libssh versions are affected, with fixes available in later releases.