Skip to main content
VulnerabilityPublished Updated

CVE-2026-3731: libssh vulnerability

Affects libsshSource GCVE Database

0
Authoritative record:CVE-2026-3731· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.11.3-1ubuntu2 when convenient.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.11.3-1ubuntu2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu libssh package to 0.11.3-1ubuntu2.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=resoluteOther threatsAffected
  • <0.11.3-1ubuntu2
Fixed in
  • 0.11.3-1ubuntu2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

USN-8093-1 fixed a vulnerability in libssh. This update provides the corresponsing fix for Ubuntu 26.04 LTS. Original advisory details: It was discovered that libssh incorrectly performed bounds checking when processing SFTP extensions. If a client application queried extension data out of bounds, it could cause the application to crash, resulting in a denial of service, or exhibit unintended behavior.

References

Community reviews

Loading reviews…