Skip to main content
CVE-2026-55200VulnerabilityPublished Updated

libssh2 1.11.1, fixed

Affects libssh2Source GCVE Database

0
Authoritative record:CVE-2026-55200· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical · fixed in 1.11.1-1ubuntu0.25.10.2 : patch libssh2 as a priority.

Data as of 28 Oct 2026, 22:28 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.11.1-1ubuntu0.25.10.2, 1.11.1-1ubuntu0.26.04.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 27 hours before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , the same day as disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu libssh2 to 1.11.1-1ubuntu0.25.10.2 (package) or 1.11.1-1ubuntu0.26.04.2 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlibssh2pkg:deb/ubuntu/libssh2?arch=source&distro=resoluteOther threatsAffected
  • <1.11.1-1ubuntu0.26.04.2
Fixed in
  • 1.11.1-1ubuntu0.26.04.2
Ubuntu 25.10libssh2pkg:deb/ubuntu/libssh2?arch=source&distro=questingOther threatsAffected
  • <1.11.1-1ubuntu0.25.10.2
Fixed in
  • 1.11.1-1ubuntu0.25.10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

libssh2 1.11.1, fixed in commit 97acf3d, contains an out-of-bounds write vulnerability in ssh2_transport_read() that fails to enforce upper bounds on packet_length field. Remote attackers can send crafted SSH packets with excessively large packet_length values to corrupt heap memory and achieve remote code execution.

References

Community reviews

Loading reviews…