Skip to main content
VulnerabilityPublished

CVE-2026-95114: libwebsockets security update

Affects libwebsocketsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-95114· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.3.3-9.oe2403sp4 soon.

Data as of 29 Oct 2026, 10:49 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.3-9.oe2403sp4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libwebsockets to 4.3.3-9.oe2403sp4.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP4libwebsocketspkg:rpm/openEuler/libwebsockets&distro=openEuler-24.03-LTS-SP4Other threatsAffected
  • <4.3.3-9.oe2403sp4
Fixed in
  • 4.3.3-9.oe2403sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading libwebsockets to version 4.3.3-9.oe2403sp4 or later. Applying this official fix will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

Libwebsockets contains an out-of-bounds read vulnerability in the LEJP incremental parser that can be exploited remotely to cause a denial of service (CVE-2026-95114). This vulnerability is addressed in version 4.3.3-9.oe2403sp4. The issue has a high severity rating with a CVSS score of 7.5, indicating a significant impact on availability but no impact on confidentiality or integrity.

References

Community reviews

Loading reviews…