Skip to main content
VulnerabilityPublished

CVE-2026-95114: libwebsockets security update

Affects libwebsocketsSource GCVE Database

0
Compare
Authoritative record:CVE-2026-95114· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.3.3-9.oe2403sp1 soon.

Data as of 29 Oct 2026, 10:48 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.3-9.oe2403sp1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libwebsockets to 4.3.3-9.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1libwebsocketspkg:rpm/openEuler/libwebsockets&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <4.3.3-9.oe2403sp1
Fixed in
  • 4.3.3-9.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade libwebsockets to version 4.3.3-9.oe2403sp1 or later where the vulnerability has been fixed. Applying this official patch fully mitigates the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

Libwebsockets versions prior to 4.3.3-9.oe2403sp1 contain an out-of-bounds read vulnerability in the LEJP incremental parser that can be exploited remotely to cause a denial of service. This vulnerability is tracked as CVE-2026-95114 and has a high severity rating. A patch is available in version 4.3.3-9.oe2403sp1 to address this issue.

References

Community reviews

Loading reviews…