Skip to main content
VulnerabilityPublished Updated

CVE-2026-63676: Libyaml perl · backtracking leading to exponential load time

Affects libyaml-perlSource GCVE Database

0

Not known to be exploited · fixed in 1.30-1ubuntu0.22.04.1 : update libyaml-perl when convenient.

Data as of 18 Oct 2026, 04:22 UTC

Severity
Medium

Rated by Threat Radar · CVSS not yet scored by NVD

Patch
Available – fixed in 1.30-1ubuntu0.22.04.1, 1.31-1ubuntu0.24.04.1, 1.15-1ubuntu0.1~esm1 +3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10libyaml-perlpkg:deb/ubuntu/libyaml-perl?arch=source&distro=stonkingOther threatsAffected
  • =1.31-1
Fixed in–
Ubuntu 26.04 LTSlibyaml-perlpkg:deb/ubuntu/libyaml-perl?arch=source&distro=resoluteOther threatsAffected
  • =1.31-1
Fixed in–
Ubuntu Pro 26.04 LTSlibyaml-perlpkg:deb/ubuntu/libyaml-perl?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • <1.31-1ubuntu0.26.04.1~esm1
Fixed in
  • 1.31-1ubuntu0.26.04.1~esm1
Ubuntu 24.04 LTSlibyaml-perlpkg:deb/ubuntu/libyaml-perl?arch=source&distro=nobleOther threatsAffected
  • <1.31-1ubuntu0.24.04.1
Fixed in
  • 1.31-1ubuntu0.24.04.1
Ubuntu 22.04 LTSlibyaml-perlpkg:deb/ubuntu/libyaml-perl?arch=source&distro=jammyOther threatsAffected
  • <1.30-1ubuntu0.22.04.1
Fixed in
  • 1.30-1ubuntu0.22.04.1
Ubuntu 20.04 LTSlibyaml-perlpkg:deb/ubuntu/libyaml-perl?arch=source&distro=focalOther threatsAffected
  • =1.29-1
  • =1.30-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to perl-YAML-1.320.0-1.1 or later. Users should update affected libyaml-perl packages to the fixed version provided by their distribution. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-63676 is a security vulnerability in the libyaml-perl package causing backtracking that leads to exponential load time. This issue affects multiple specific versions of libyaml-perl and has been fixed in perl-YAML-1.320.0-1.1 on openSUSE Tumbleweed. The vulnerability is rated medium severity and no known exploits are reported in the wild. A patch is available to address this issue.

References

Community reviews

Loading reviews…