CVE-2025-40001: linux-aws, linux-oracle vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.17.0-1007.7 soon.
Data as of 3 Nov 2026, 17:31 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.17.0-1007.7
Exploitation evidence
Disclosed: evidence found.
CVE published 17 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu to 6.17.0-1007.7.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing these vulnerabilities is available. Users should update to linux-aws and linux-oracle kernel packages version 6.17.0-1007.7 or later. After updating, a system reboot is required to apply the fixes. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8029-2 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting numerous subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The vulnerabilities impact a wide range of kernel components including various CPU architectures, drivers, filesystems, networking, and kernel subsystems. A security update has been released to address these flaws.
References
- ubuntu.com/security/notices/USN-8029-2 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40001 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40002 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40003 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40004 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40029 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40030 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40031 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40032 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40033 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40034 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40035 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40036 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40037 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40038 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40039 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40040 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40042 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40043 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40044 (opens in a new tab)