Skip to main content
VulnerabilityPublished Updated

CVE-2025-21729: linux-azure, linux-azure-6.8 vulnerabilities

Affects Linux kernelSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-1044.50~22.04.1 : update Linux kernel when convenient.

Data as of 27 Oct 2026, 06:42 UTC

Severity
Unrated

Rated by Threat Radar · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1044.50~22.04.1, 6.8.0-1044.50

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1044.50~22.04.1 (linux-azure-6.8 package) or 6.8.0-1044.50 (linux-azure package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1044.50
Fixed in
  • 6.8.0-1044.50
Ubuntu 22.04 LTSlinux-azure-6.8pkg:deb/ubuntu/linux-azure-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1044.50~22.04.1
Fixed in
  • 6.8.0-1044.50~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Jean-Claude Graf, Sandro Rüegge, Ali Hajiabadi, and Kaveh Razavi discovered that the Linux kernel contained insufficient branch predictor isolation between a guest and a userspace hypervisor for certain processors. This flaw is known as VMSCAPE. An attacker in a guest VM could possibly use this to expose sensitive information from the host OS. (CVE-2025-40300) Several security issues were discovered in the Linux kernel. An attacker could possibly use these to compromise the system. This update corrects flaws in the following subsystems: - Cryptographic API; - HSI subsystem; - Media drivers; - Network drivers; - Bluetooth subsystem; - Timer subsystem; - Memory management; - Appletalk network protocol; - Netfilter; - TLS protocol; (CVE-2025-21729, CVE-2025-37838, CVE-2025-37958, CVE-2025-38118, CVE-2025-38227, CVE-2025-38352, CVE-2025-38616, CVE-2025-38666, CVE-2025-38678, CVE-2025-39964, CVE-2025-39993, CVE-2025-40018)

References

Community reviews

Loading reviews…