CVE-2025-21796: linux-fips, linux-gcp-fips vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 5.4.0-1125.135 : patch Linux kernel soon.
Data as of 31 Oct 2026, 01:29 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 5.4.0-1125.135, 5.4.0-1154.163+fips1
Exploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu to 5.4.0-1125.135 (linux-fips package) or 5.4.0-1154.163+fips1 (linux-gcp-fips package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro FIPS-updates 20.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro FIPS-updates 20.04 LTSlinux-gcp-fipspkg:deb/ubuntu/linux-gcp-fips?arch=source&distro=fips-updates/focalOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the security updates provided by Ubuntu in the linux-fips and linux-gcp-fips packages at versions 5.4.0-1125.135 or later and 5.4.0-1154.163+fips1 or later. After updating, reboot the system to activate the fixes. Recompile and reinstall all third-party kernel modules due to an ABI change introduced by the update. Follow the official Ubuntu security notice USN-7795-2 for detailed update instructions.
Description
Multiple security vulnerabilities were identified in the Linux kernel affecting several subsystems including Ext4, NFS server daemon, packet sockets, network traffic control, and VMware vSockets driver. These flaws could potentially allow an attacker to compromise the system. The issues are addressed in updated Linux kernel packages provided by Ubuntu with FIPS certification. Users must apply these updates and reboot their systems. Due to ABI changes, recompilation of third-party kernel modules is required after the update.
References
- ubuntu.com/security/notices/USN-7795-2 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21796 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37785 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38477 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38617 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38618 (opens in a new tab)