CVE-2025-40025: linux-gcp vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.17.0-1004.4 soon.
Data as of 3 Nov 2026, 17:43 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.17.0-1004.4
Exploitation evidence
Disclosed: evidence found.
CVE published 5 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu linux-gcp package to 6.17.0-1004.4.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied immediately. Update the linux-gcp kernel package to version 6.17.0-1004.4 or later and reboot the system to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled after the update. Standard system upgrades will handle this automatically unless kernel metapackages were manually removed.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for Google Cloud Platform (linux-gcp), affecting several subsystems including x86 architecture, Cryptographic API, Android drivers, TTY drivers, F2FS file system, and 9P file system network protocol. These flaws could potentially allow an attacker to compromise the system. A security update addressing these issues has been released, requiring a system reboot and recompilation of third-party kernel modules due to an ABI change.
References
- ubuntu.com/security/notices/USN-7906-2 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40025 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40026 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40027 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40028 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40108 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40109 (opens in a new tab)