Skip to main content
VulnerabilityPublished Updated

CVE-2024-27407: linux-gke, linux-ibm-5.15, linux-kvm vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 5.15.0-1085.88~20.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:36 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 5.15.0-1085.88~20.04.1, 5.15.0-1088.94, 5.15.0-1087.92

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 5.15.0-1085.88~20.04.1 (linux-ibm-5.15 package) or 5.15.0-1088.94 (linux-gke package) or 5.15.0-1087.92 (linux-kvm package).

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-1088.94
Fixed in
  • 5.15.0-1088.94
Ubuntu 22.04 LTSlinux-kvmpkg:deb/ubuntu/linux-kvm?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-1087.92
Fixed in
  • 5.15.0-1087.92
Ubuntu Pro 20.04 LTSlinux-ibm-5.15pkg:deb/ubuntu/linux-ibm-5.15?arch=source&distro=esm-infra/focalOther threatsAffected
  • <5.15.0-1085.88~20.04.1
Fixed in
  • 5.15.0-1085.88~20.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating to the fixed kernel versions listed in the Ubuntu advisory USN-7726-4. After updating, a system reboot is required to activate the fixes. Due to an ABI change, any third-party kernel modules must be recompiled and reinstalled. Users of Ubuntu 20.04 LTS and 22.04 LTS should follow the update instructions provided by Ubuntu to ensure full remediation.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting the NTFS3 file system and network traffic control subsystems. These flaws could potentially allow an attacker to compromise the system. Fixes have been released for various Linux kernel versions used in Ubuntu 20.04 LTS and 22.04 LTS, including kernels for IBM cloud, Google Container Engine, and KVM environments. Users are advised to update and reboot their systems to apply the patches. Due to ABI changes, third-party kernel modules may need recompilation after the update.

References

Community reviews

Loading reviews…