CVE-2025-37947: linux-hwe-6.14, linux-oem-6.14 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 6.14.0-28.28~24.04.1 : patch Linux kernel soon.
Data as of 3 Nov 2026, 17:27 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.14.0-28.28~24.04.1, 6.14.0-1010.10
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu to 6.14.0-28.28~24.04.1 (linux-hwe-6.14 package) or 6.14.0-1010.10 (linux-oem-6.14 package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-hwe-6.14pkg:deb/ubuntu/linux-hwe-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-oem-6.14pkg:deb/ubuntu/linux-oem-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. Ubuntu has released updated kernel packages (linux-hwe-6.14 and linux-oem-6.14) that fix these vulnerabilities. Users should update to kernel versions 6.14.0-28.28~24.04.1 or 6.14.0-1010.10 or later as appropriate. After updating, a system reboot is required to apply the fixes. Note that due to ABI changes, third-party kernel modules must be recompiled and reinstalled. Follow the official Ubuntu security notice USN-7699-2 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and architectures. These flaws could potentially allow an attacker to compromise the system. The issues impact various components including ARM64, RISC-V, and x86 architectures, GPU drivers, network drivers, file systems, and more. Fixes have been released in updated Linux kernel packages for Ubuntu 24.04 LTS.
References
- ubuntu.com/security/notices/USN-7699-2 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37947 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37948 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37949 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37950 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37951 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37952 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37954 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37955 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37956 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37957 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37958 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37959 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37960 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37961 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37962 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37963 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37964 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37965 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37966 (opens in a new tab)