Skip to main content
VulnerabilityPublished Updated

CVE-2025-54505: linux-hwe-7.0 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-54505· Low 2.0

Not known to be exploited · CVSS 2.0 Low : upgrade to 7.0.0-28.28~24.04.1 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-28.28~24.04.1
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu linux-hwe-7.0 package to 7.0.0-28.28~24.04.1.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-hwe-7.0pkg:deb/ubuntu/linux-hwe-7.0?arch=source&distro=nobleOther threatsAffected
  • <7.0.0-28.28~24.04.1
Fixed in
  • 7.0.0-28.28~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in linux-hwe-7.0 version 7.0.0-28.28~24.04.1. Users should apply this update promptly to mitigate the risks. The vendor advisory (https://ubuntu.com/security/notices/USN-8569-1) provides the official patch and further details. No additional mitigations are specified beyond applying the update.

Description

Multiple security vulnerabilities were discovered in the linux-hwe-7.0 kernel, affecting various subsystems and architectures. These include speculative execution data leaks on some AMD processors, privilege escalation via operation cache isolation flaws on AMD Zen 2, logic flaws in socket buffer fragment handling that may allow privilege escalation or container escape, race conditions exposing sensitive information, and multiple memory corruption and denial-of-service issues related to AppArmor notifications. The vulnerabilities collectively could allow local attackers to expose sensitive information, escalate privileges, cause resource exhaustion, kernel panics, or memory corruption. A security update fixing these issues is available.

References

Community reviews

Loading reviews…