CVE-2026-23272: linux-ibm, linux-ibm-5.4 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1107.112~18.04.1 : patch Linux kernel soon.
Data as of 5 Nov 2026, 00:01 UTC
Thin evidence
One scorer or none| CNA (Linux) | CVSS 3.1 | 7.8 |
|---|
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.4.0-1107.112~18.04.1, 5.4.0-1107.112
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the Ubuntu to 5.4.0-1107.112~18.04.1 (linux-ibm-5.4 package) or 5.4.0-1107.112 (linux-ibm package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 20.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSlinux-ibm-5.4pkg:deb/ubuntu/linux-ibm-5.4?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches provided by Ubuntu by upgrading to linux-ibm-5.4 kernel versions 5.4.0-1107.112~18.04.1 or 5.4.0-1107.112 or later. After updating, reboot the system to activate the fixes. Note that due to ABI changes, third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8616-1 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel, specifically affecting the linux-ibm-5.4 kernel versions. These include logic flaws in the XFRM ESP-in-TCP and RxRPC networking subsystems related to improper handling of shared page fragments during socket buffer operations, known as Dirty Frag and Fragnesia. A local attacker could exploit these flaws to escalate privileges or potentially escape container environments. Additional vulnerabilities affect various subsystems such as InfiniBand drivers, NVME drivers, SCSI, USB over IP, NFS, SMB, tracing infrastructure, and multiple networking protocols. Fixes are available in updated kernel versions.
References
- ubuntu.com/security/notices/USN-8616-1 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23272 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23455 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31402 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31418 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31607 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31637 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31649 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31659 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31682 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31685 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43011 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43037 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43038 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43117 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43284 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43383 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43407 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43414 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43494 (opens in a new tab)