Skip to main content
VulnerabilityPublished Updated

CVE-2025-10263: linux, linux-aws, linux-aws-7.0, linux-gcp, linux-gke, linux-hwe-7.0, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-10263· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 7.0.0-1012.12~24.04.1 : patch Linux kernel as a priority.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1012.12~24.04.1, 7.0.0-31.31~24.04.1, 7.0.0-31.31 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31
Fixed in
  • 7.0.0-31.31
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1012.12
Fixed in
  • 7.0.0-1012.12
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1011.11
Fixed in
  • 7.0.0-1011.11
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.7
Fixed in
  • 7.0.0-1006.7
Ubuntu 26.04 LTSlinux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31.1
Fixed in
  • 7.0.0-31.31.1
Ubuntu 24.04 LTSlinux-aws-7.0pkg:deb/ubuntu/linux-aws-7.0?arch=source&distro=nobleOther threatsAffected
  • <7.0.0-1012.12~24.04.1
Fixed in
  • 7.0.0-1012.12~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the available security updates by upgrading to the fixed kernel versions listed in the Ubuntu advisory USN-8726-1. After updating, reboot the system to ensure all changes take effect. Due to an unavoidable ABI change in the kernel updates, recompile and reinstall all third-party kernel modules. Follow the vendor's official update instructions to fully remediate the vulnerabilities.

Description

Multiple security vulnerabilities were discovered in the Linux kernel, including a critical issue affecting some Arm processors where a broadcast TLB invalidation could complete before memory writes were globally observed. This flaw could allow a local attacker to write to memory after permissions were revoked, potentially bypassing memory protections or escalating privileges. The update addresses numerous flaws across a wide range of kernel subsystems and architectures. Users must update to fixed kernel versions and reboot to apply the patches. Due to ABI changes, third-party kernel modules require recompilation and reinstallation.

References

Community reviews

Loading reviews…