Skip to main content
CVE-2025-37798VulnerabilityPublished Updated

linux, linux-aws, linux-gcp, linux-gcp-6.11, linux-hwe-6.11, linux-oracle, linux-raspi, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.11.0-1017.17~24.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:50 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.11.0-1017.17~24.04.1, 6.11.0-29.29~24.04.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.11.0-1017.17~24.04.1 (linux-gcp-6.11 package) or 6.11.0-29.29~24.04.1 (linux-hwe-6.11 package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-gcp-6.11pkg:deb/ubuntu/linux-gcp-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1017.17~24.04.1
Fixed in
  • 6.11.0-1017.17~24.04.1
Ubuntu 24.04 LTSlinux-hwe-6.11pkg:deb/ubuntu/linux-hwe-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-29.29~24.04.1
Fixed in
  • 6.11.0-29.29~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately by updating to the fixed Linux kernel versions listed in the Ubuntu advisory USN-7610-1. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Users who have not removed standard kernel metapackages will have this handled automatically during the upgrade.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting subsystems such as Netfilter and network traffic control. These flaws could potentially allow an attacker to compromise affected systems. The issues have been addressed in updated Linux kernel packages for various Ubuntu releases and flavors, including linux-gcp-6.11. Users must apply the updates and reboot their systems. Due to ABI changes, recompilation of third-party kernel modules may be necessary.

References

Community reviews

Loading reviews…