Skip to main content
VulnerabilityPublished Updated

CVE-2026-31419: linux-lowlatency-hwe-5.15 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-31419· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 5.15.0-179.189~20.04.1 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Sources agree

CVSS scores by source
CNA (Linux)CVSS 3.17.8
ADP (redhat-SADP)CVSS 3.17.0
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-179.189~20.04.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu linux-lowlatency-hwe-5.15 package to 5.15.0-179.189~20.04.1.

Affected software

ProductAffectedFixed in
Ubuntu Pro 20.04 LTSlinux-lowlatency-hwe-5.15pkg:deb/ubuntu/linux-lowlatency-hwe-5.15?arch=source&distro=esm-infra/focalOther threatsAffected
  • <5.15.0-179.189~20.04.1
Fixed in
  • 5.15.0-179.189~20.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in linux-lowlatency-hwe-5.15 kernel version 5.15.0-179.189~20.04.1. Users should apply the update promptly and reboot their systems to ensure all changes take effect. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. Follow the instructions in the Ubuntu security notice USN-8305-2 for proper update procedures.

Description

Multiple security vulnerabilities were discovered in the Linux kernel low latency hardware enablement (HWE) 5.15 series, including a flaw in the algif_aead cryptographic module known as Copy Fail. These issues affect subsystems such as the Cryptographic API, Ethernet bonding driver, Packet sockets, and TLS protocol. A local attacker could exploit these vulnerabilities to escalate privileges or potentially escape container environments. The vulnerabilities are addressed in the linux-lowlatency-hwe-5.15 kernel update version 5.15.0-179.189~20.04.1.

References

Community reviews

Loading reviews…