Skip to main content
VulnerabilityPublished Updated

CVE-2025-21796: linux-oracle-5.4 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited : upgrade to 5.4.0-1149.159~18.04.1 soon.

Data as of 31 Oct 2026, 01:29 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 5.4.0-1149.159~18.04.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu linux-oracle-5.4 package to 5.4.0-1149.159~18.04.1.

Affected software

ProductAffectedFixed in
Ubuntu Pro 18.04 LTSlinux-oracle-5.4pkg:deb/ubuntu/linux-oracle-5.4?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <5.4.0-1149.159~18.04.1
Fixed in
  • 5.4.0-1149.159~18.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in linux-image-5.4.0-1149.159~18.04.1 for Ubuntu 18.04 LTS (bionic). Users should apply this update promptly and reboot their systems to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled after the update. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-7795-4 for detailed instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for Oracle Cloud systems, affecting subsystems including Ext4, NFS server daemon, packet sockets, network traffic control, and VMware vSockets driver. These flaws could potentially allow an attacker to compromise the system. A security update addressing these issues is available and requires a system reboot. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled after the update.

References

Community reviews

Loading reviews…