Skip to main content
VulnerabilityPublished Updated

CVE-2024-50157: linux-oracle, linux-oracle-6.8, linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-1027.28~22.04.1 : update Linux kernel when convenient.

Data as of 29 Oct 2026, 22:33 UTC

Severity
Unrated

Rated by Threat Radar · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1027.28~22.04.1, 6.8.0-1027.28, 6.8.0-1029.33

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1027.28~22.04.1 (linux-oracle-6.8 package) or 6.8.0-1027.28 (linux-oracle package) or 6.8.0-1029.33 (linux-raspi package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1027.28
Fixed in
  • 6.8.0-1027.28
Ubuntu 24.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1029.33
Fixed in
  • 6.8.0-1029.33
Ubuntu 22.04 LTSlinux-oracle-6.8pkg:deb/ubuntu/linux-oracle-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1027.28~22.04.1
Fixed in
  • 6.8.0-1027.28~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

It was discovered that the CIFS network file system implementation in the Linux kernel did not properly verify the target namespace when handling upcalls. An attacker could use this to expose sensitive information. (CVE-2025-2312) Several security issues were discovered in the Linux kernel. An attacker could possibly use these to compromise the system. This update corrects flaws in the following subsystems: - GPIO subsystem; - GPU drivers; - InfiniBand drivers; - IRQ chip drivers; - Network drivers; - Mellanox network drivers; - i.MX PM domains; - SCSI subsystem; - USB Serial drivers; - AFS file system; - GFS2 file system; - File systems infrastructure; - File system notification infrastructure; - Overlay file system; - Proc file system; - SMB network file system; - Timer subsystem; - Kernel CPU control infrastructure; - Memory management; - Networking core; - DCCP (Datagram Congestion Control Protocol); - IPv6 networking; - IEEE 802.15.4 subsystem; - Open vSwitch; - Network traffic control; - VMware vSockets driver; (CVE-2025-21943, CVE-2025-21672, CVE-2024-57952, CVE-2024-57949, CVE-2025-21683, CVE-2025-21690, CVE-2025-21699, CVE-2025-21676, CVE-2024-57924, CVE-2025-21694, CVE-2024-57948, CVE-2025-21675, CVE-2024-57951, CVE-2025-21692, CVE-2025-21684, CVE-2025-21668, CVE-2025-21665, CVE-2025-21667, CVE-2025-21670, CVE-2025-21674, CVE-2025-21697, CVE-2024-53124, CVE-2025-21666, CVE-2025-21682, CVE-2025-21680, CVE-2025-21681, CVE-2025-21691, CVE-2025-21669, CVE-2025-21673, CVE-2024-50157, CVE-2025-21689, CVE-2025-21678)

References

Community reviews

Loading reviews…