CVE-2025-21796: linux-raspi-5.4 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 5.4.0-1134.147~18.04.1 soon.
Data as of 31 Oct 2026, 01:29 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 5.4.0-1134.147~18.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 7 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-raspi-5.4 package to 5.4.0-1134.147~18.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 18.04 LTSlinux-raspi-5.4pkg:deb/ubuntu/linux-raspi-5.4?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update to linux-raspi-5.4 version 5.4.0-1134.147~18.04.1 or later. After updating, a system reboot is required to apply the changes. Due to an ABI change, any third-party kernel modules must be recompiled and reinstalled. Standard system upgrades will handle this automatically unless kernel metapackages were manually removed.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi systems, affecting subsystems such as Ext4 file system, NFS server daemon, packet sockets, network traffic control, and VMware vSockets driver. These issues could potentially allow an attacker to compromise the system. A patch fixing these vulnerabilities is available in version 5.4.0-1134.147~18.04.1. Users are advised to update and reboot their systems. Due to an ABI change, third-party kernel modules may need recompilation and reinstallation.
References
- ubuntu.com/security/notices/USN-7795-5 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21796 (opens in a new tab)
- ubuntu.com/security/CVE-2025-37785 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38477 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38617 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38618 (opens in a new tab)