Skip to main content
VulnerabilityPublished Updated

CVE-2026-23272: linux-raspi, linux-raspi-5.4 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-23272· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1144.157~18.04.1 : patch Linux kernel soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Linux)CVSS 3.17.8
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.0-1144.157~18.04.1, 5.4.0-1144.157
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu to 5.4.0-1144.157~18.04.1 (linux-raspi-5.4 package) or 5.4.0-1144.157 (linux-raspi package).

Affected software

ProductAffectedFixed in
Ubuntu Pro 20.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=esm-infra/focalOther threatsAffected
  • <5.4.0-1144.157
Fixed in
  • 5.4.0-1144.157
Ubuntu Pro 18.04 LTSlinux-raspi-5.4pkg:deb/ubuntu/linux-raspi-5.4?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <5.4.0-1144.157~18.04.1
Fixed in
  • 5.4.0-1144.157~18.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Update to linux-raspi-5.4 kernel versions 5.4.0-1144.157 or 5.4.0-1144.157~18.04.1 as provided by the Ubuntu security notice USN-8615-2. After updating, a system reboot is required to apply the fixes. Note that due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Follow vendor instructions for updating and recompiling modules.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi systems, including a logic flaw in the XFRM ESP-in-TCP subsystem known as Fragnesia. These vulnerabilities could allow a local attacker to escalate privileges or potentially escape container environments. The issues affect various kernel subsystems such as networking drivers, storage drivers, file systems, and networking protocols. Fixes have been released in updated kernel versions.

References

Community reviews

Loading reviews…