CVE-2025-38003: linux-realtime-6.14 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.14.0-1012.12~24.04.1 soon.
Data as of 3 Nov 2026, 17:29 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.14.0-1012.12~24.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu linux-realtime-6.14 package to 6.14.0-1012.12~24.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-realtime-6.14pkg:deb/ubuntu/linux-realtime-6.14?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied immediately. Users should upgrade to linux-image-6.14.0-1012.12~24.04.1 or later and reboot their systems to apply the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled after the update. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-7769-2 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel version linux-realtime-6.14 affecting a wide range of subsystems including various architectures, drivers, filesystems, and networking components. These issues could potentially allow an attacker to compromise the system. A security update has been released to address these flaws, and users are advised to apply the update and reboot their systems. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required.
References
- ubuntu.com/security/notices/USN-7769-2 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38003 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38004 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38029 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38031 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38032 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38033 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38034 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38035 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38036 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38037 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38038 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38039 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38040 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38041 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38042 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38043 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38044 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38045 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38047 (opens in a new tab)