linux-realtime, linux-realtime-6.17 vulnerabilities
Affects Linux kernelSource GCVE Database
Mentioned vulnerabilities
Fixed in 6.17.0-1017.19~24.04.1 : patch Linux kernel soon.
Data as of 30 Jul 2026, 19:44 UTC
Rated by Threat Radar
- Patch
- Available – fixed in 6.17.0-1017.19~24.04.1, 6.17.0-1017.19
What to do
Upgrade the Ubuntu to 6.17.0-1017.19~24.04.1 (linux-realtime-6.17 package) or 6.17.0-1017.19 (linux-realtime package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-realtimepkg:deb/ubuntu/linux-realtime@6.17.0-1017.19?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu Pro Realtime 24.04 LTSlinux-realtime-6.17pkg:deb/ubuntu/linux-realtime-6.17@6.17.0-1017.19~24.04.1?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in linux-realtime kernel versions 6.17.0-1017.19 and later. Users should upgrade to these or newer patched versions to remediate the vulnerabilities. Since this is not a cloud service, system administrators must apply the updated kernel packages manually or via their distribution's update mechanisms. There are no vendor advisories indicating that no action is required or that the issue is already mitigated without patching.
Description
Multiple security vulnerabilities were discovered in the Linux kernel affecting the linux-realtime-6.17 series and related versions. These issues impact a wide range of kernel subsystems including ARM64 architecture, block layer, cryptographic API, various network drivers, file systems, and networking protocols. The vulnerabilities could potentially allow an attacker to compromise the system. Several specific kernel versions prior to 6.17.0-1017.19 and certain exact builds are affected. No known exploits in the wild have been reported at this time.
References
- ubuntu.com/security/notices/USN-8490-2 (opens in a new tab)
- ubuntu.com/security/CVE-2026-22984 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23272 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23278 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23392 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23427 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23428 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23450 (opens in a new tab)
- ubuntu.com/security/CVE-2026-23455 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31402 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31418 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31436 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31448 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31478 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31607 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31635 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31637 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31649 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31657 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31659 (opens in a new tab)