CVE-2024-58090: linux-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.8.1-1034.35 soon.
Data as of 31 Oct 2026, 01:36 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.1-1034.35
Exploitation evidence
Disclosed: evidence found.
CVE published 24 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-realtime package to 6.8.1-1034.35.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update to linux-realtime kernel version 6.8.1-1034.35 or later. After updating, a system reboot is required to apply the changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Follow the official Ubuntu security notice USN-7767-1 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel real-time (linux-realtime) variant affecting numerous subsystems and architectures. These flaws could potentially allow an attacker to compromise the system. The issues impact a wide range of components including ARM and x86 architectures, various device drivers, networking stacks, memory management, and more. A patch addressing these vulnerabilities is available in linux-realtime kernel version 6.8.1-1034.35. Users are advised to update and reboot to apply the fixes. Due to ABI changes, recompilation of third-party kernel modules may be required.
References
- ubuntu.com/security/notices/USN-7767-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58090 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21872 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21873 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21875 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21877 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21878 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21880 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21881 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21883 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21885 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21888 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21889 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21890 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21891 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21892 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21894 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21895 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21898 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21899 (opens in a new tab)